Outseer confirms that the incident has been resolved and services have been stable for the last 90 minutes.
Posted May 07, 2026 - 20:22 UTC
Monitoring
Please be informed that the degradation has been mitigated and services have returned to normal. We will continue to monitor and provide a further update by one hour.
Posted May 07, 2026 - 19:25 UTC
Investigating
Please be informed that an incident was detected at 18:17 UTC (07 May 26), which is impacting Online transactions. Our teams are actively investigating the issue, and we will provide a further update by one hour.
If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers: US: +1 844 268 8733 US International: +1 415 842 3467 Mexico Toll Free: +52 800 283 3431 NZ: +64 800 688 733 AU: +61 1800 268 873 UK: +44 800 640 4688
Posted May 07, 2026 - 18:33 UTC
This incident affected: US (Transactions, Back Office).