US - Version 14.2.27 Release

Scheduled for Apr 27, 06:00 - 10:00 UTC

Update

Please be informed that the maintenance initially planned for Sunday, Apr 20 , has been rescheduled to Sunday, Apr 27, 2025.

Outseer will perform scheduled maintenance in our US Region between 06:00 to 10:00 AM UTC on Sunday, Apr 27, 2025, to deploy a new version - 14.2.27, of Fraud Manager on Cloud.

Customers may experience a 5-10% intermittent SLA degradation during this maintenance window for BackOffice and online transactions from 06:00 to 08:00 UTC.

Our operations team will be closely monitoring service performance during this maintenance window.

If you have any questions regarding this scheduled release, please contact our Customer Support team at support@outseer.com or by calling us directly at one of the following numbers:

US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Apr 09, 2025 - 14:34 UTC

Scheduled

Outseer will perform scheduled maintenance in our US Region between 06:00 to 10:00 AM UTC on Sunday, Apr 20, 2025, to deploy a new version - 14.2.27, of Fraud Manager on Cloud.

Customers may experience a 5-10% intermittent SLA degradation during this maintenance window for BackOffice and online transactions from 06:00 to 08:00 UTC.

Our operations team will be closely monitoring service performance during this maintenance window.

If you have any questions regarding this scheduled release, please contact our Customer Support team at support@outseer.com or by calling us directly at one of the following numbers:

US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Apr 04, 2025 - 13:11 UTC
This scheduled maintenance affects: US (Transactions, Back Office).