US Region Incident

Incident Report for Outseer Fraud Manager

Resolved

Outseer confirms that the incident has been resolved and services have been stable for the last 90 minutes.
Posted Mar 26, 2026 - 08:51 UTC

Monitoring

Please be informed that services have been operating normally for the past hour. The incident impact was minimal and lasted less than one minute, with fewer than 1% of transactions experiencing brief service degradation. We continue to monitor and work closely with Microsoft Azure to fully mitigate the issue. Further updates will be shared within the next hour.
Posted Mar 26, 2026 - 08:10 UTC

Update

This is an update to inform you that an incident has been detected with our technology partner, Microsoft Azure. We are working closely with the Microsoft Azure team to mitigate the issue and will continue to keep you informed in next one hour.
Posted Mar 26, 2026 - 07:53 UTC

Identified

This is an update to inform you that an incident has been detected with our technology partner, Microsoft Azure. We are working closely with the Microsoft Azure team to mitigate the issue and will continue to keep you informed as we make progress
Posted Mar 26, 2026 - 06:01 UTC

Update

This is an update to inform you that our team is actively investigating the issue to identify the root cause. We will continue to keep you informed as we make progress.
Posted Mar 26, 2026 - 05:12 UTC

Update

This is an update to inform you that our team is actively investigating the issue to identify the root cause. We will continue to keep you informed as we make progress.
Posted Mar 26, 2026 - 04:05 UTC

Investigating

Please be informed that an incident was detected at 03:08 AM UTC, intermittently impacting approximately 5% of online transactions for durations of 1–2 minutes. Our teams are actively investigating the issue, and we will provide a further update by 04:00 AM UTC.

If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers:
US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Mar 26, 2026 - 03:40 UTC
This incident affected: US (Transactions, Back Office).