Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 03, 2023 - 07:00 UTC
Scheduled
Outseer will be performing scheduled maintenance in our US Region between 07:00 - 11:00 UTC on Sunday, December 3rd, 2023, for the deployment of a new version of Fraud Manager on Cloud.
During this maintenance window, it is expected that customers will experience a performance degradation of 2 – 3 minutes for up to 50% of Online and Back Office transactions. The degradation will occur approximately every 15 – 20 minutes as we deploy this new version.
Our team will be closely monitoring service performance during this period.
If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers: US: +1 844 268 8733 US International: +1 415 842 3467 Mexico Toll Free: +52 800 283 3431 NZ: +64 800 688 733 AU: +61 1800 268 873 UK: +44 800 640 4688
Posted Nov 17, 2023 - 17:31 UTC
This scheduled maintenance affected: US (Transactions, Back Office).