EU Region Incident

Incident Report for Outseer Fraud Manager

Resolved

Outseer confirms that the incident has been resolved and services are stable .
Posted Mar 27, 2026 - 11:19 UTC

Update

Outseer confirms that the incident has been resolved and services are stable .
Posted Mar 27, 2026 - 11:18 UTC

Monitoring

Please be informed that a solution has been implemented to address the identified issue. We are continuing to monitor the service to ensure normal operation and stability. The next update will be provided within one hour.
Posted Mar 27, 2026 - 09:05 UTC

Identified

Please be informed that FMoC service accessibility has improved; however, slight degradation is still being observed. Our team continues to monitor and will provide the next update within the hour.
Posted Mar 27, 2026 - 08:54 UTC

Investigating

Please be informed that an incident was detected at 08:00 AM UTC (27 Mar 26), which is impacting Online transactions. Our teams are actively investigating the issue, and we will provide a further update by one hour.

If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers:

US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted Mar 27, 2026 - 08:09 UTC
This incident affected: EU (Transactions, Back Office).