SLA Timeout
Incident Report for Outseer Fraud Manager
Resolved
This incident has been resolved.
Posted May 28, 2023 - 18:57 UTC
Update
Our team is continuing to investigate the issue, we provide our further update by 18:48 UTC.
Posted May 28, 2023 - 17:48 UTC
Investigating
Please be advised that an incident has been detected which impacts the components below for a few customers. Our teams are investigating the incident and we will provide a further update by 16:48 UTC.

If you have any questions regarding this incident please contact our Customer Support team at support@outseer.com or by calling us directly on one of the following numbers:
US: +1 844 268 8733
US International: +1 415 842 3467
Mexico Toll Free: +52 800 283 3431
NZ: +64 800 688 733
AU: +61 1800 268 873
UK: +44 800 640 4688
Posted May 28, 2023 - 15:49 UTC
This incident affected: US (Transactions).